[Solved] Get a SQLite3 db in Libre Office (via ODBC) using Ubuntu 11.04 (64bit)

1 reply [Last post]
nine
Offline
Last seen: 2 years 44 weeks ago
Title:
Joined: 28 Dec 2011
Posts: 2

I'm stuck with this. I had SQLite working with Open Office in the past. But since then i reinstalled my machine and so... Now I can't get it to work.

i pretty muched followed this guide: http://documentation.openoffice.org/HOW_TO/data_source/SQLite.pdf

Except that I changed (with sudo ODBCConfig) the SQLite drivers config to:

Driver: /usr/lib/odbc/libsqlite3odbc.so 
Driver64: /usr/lib64/odbc/libsqlite3odbc.so 
Setup: /usr/lib/odbc/libsqlite3odbc.so 
Setup64: /usr/lib64/odbc/libsqlite3odbc.so 

(Those files exist on my system)

I also added my database under the User DSN tab.

When I start Libre Office Base and browse for a ODBC DataSource it turns up empty. I guess this is'nt easy to answer without having access to my system. But maybe anyone has an idea? Or some way to debug the connection that I'm not aware of?

Here are some info about my packages:

$ dpkg --get-selections |grep odbc
libodbcinstq1c2             install
libsqliteodbc               install
odbcinst                    install
odbcinst1debian2                install
unixodbc                    install
unixodbc-bin                install

$ dpkg --get-selections |grep sqlite
libaprutil1-dbd-sqlite3         install
libmono-sqlite1.0-cil           install
libmono-sqlite2.0-cil           install
libqt4-sql-sqlite               install
libsqlite0                  install
libsqlite3-0                install
libsqliteodbc               install
sqlite3                 install
sqlitebrowser               install
sqliteman                   install
sqliteman-doc               install

Thanks alot!

nine
Offline
Last seen: 2 years 44 weeks ago
Title:
Joined: 28 Dec 2011
Posts: 2
Solved!

Ok the problem was pretty obvious. I used the command: sudo ODBCConfig to configure the driver (which the odbcsqlite package really seemed to have done for me already).

Anyway, without restarting ODBCConfig as local user I configured the database under the User DSN tab. As I would expect, if I've just used my brain a little more, the database would then only be shown to user root (I never verified this, but it seems obvious).

My solution was to restart ODBCConfig as the local user (i. e. without sudo) and then add the database. Then it worked just fine.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.