[SOLVED] LibreOffice requires a Java runtime environment to perform this task. Please install a jre and restart libreoffice.

2 replies [Last post]
abcuser
Offline
Last seen: 2 years 6 weeks ago
Title: ★★★★★
Joined: 29 Jan 2011
Posts: 146

Hi,
I have installed LibreOffice 3.3 on Windows xp sp3. During install I have deselected Base and left all other settings default.
During install I have had several messages displayed that on my computer there is no JRE installed. I always thought that JRE is only required by using Base, it looks I was wrong.

Now it appears everything is working fine except for Help | LibreOffice Help | Find. When I write a search string into Find box and click on Find button I get error:

"LibreOffice requires a Java runtime environment to perform this task. Please install a JRE and restart LibreOffice."


I have looked through my system and I have! v1.5.0.22 JRE installed. But when looking into LibreOffice settings in Tools | Options | LibreOffice | Java there is empty window. I have tried to add a path to this window using Add button and specified path:

"C:\Program Files\Java\jre1.5.0_22\bin" where java.exe file is, but I get error message: "The folder you selected does not contain a Java runtime environment. Please select a different folder."


How can I enable Help | Find box to start searching?

Regards

abcuser
Offline
Last seen: 2 years 6 weeks ago
Title: ★★★★★
Joined: 29 Jan 2011
Posts: 146
Hi, I have asked the same

Hi,

I have asked the same question on IRC and got an answer that LibreOffice only supports the JRE version 6, so I have uninstalled JRE version 5 (=1.5.0.22) and downloaded the latest "JRE v6 update23" from web page: http://www.java.com/en/download/index.jsp

I installed this JRE and opened LibreOffice. I clicked on Tools | Options | LibreOffice | Java and it looks like LibreOffice recognized installed JRE.

Now Help menu options work fine. Problem solved.

Regards

eikelein
Offline
Last seen: 1 year 3 weeks ago
Title:
Joined: 31 Mar 2011
Posts: 8
How can this be SOLVED?

Most everybody including JAVA releases new versions because of BUG FIXES!

Since when is requiring an outdated, i.e. buggy version of a supporting software package a solution?

As much as I hate to have to say this, but these things are why LibreOffice as it is now will NEVER become mainstream. And I know a few other examples as well.


Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.